Author Topic: GARMIN 660 COMPATABILITY PROBLEM  (Read 1144 times)

0 Members and 1 Guest are viewing this topic.

OfflineRTman10

  • Hero Member
  • *****
  • Posts: 935
  • Country: england
  • GTL Exclusive (Exchanged for R1200RT LE)
    GARMIN 660 COMPATABILITY PROBLEM
    « on: 2015-02-10 11:44:18 »
    Has anybody who uses a 660 had a message appear on start up saying "The USB cable is connected to the wrong port". Message then goes away and everything works.  Garmin UK have suggested its a compatibility issue, but I'm not so sure. 

    OfflineFP-NLD

    • Global Moderator
    • *****
    • Posts: 786
    • Country: nl
      Re: GARMIN 660 COMPATABILITY PROBLEM
      « Reply #1 on: 2015-02-10 13:23:25 »
      I use a 660 but it doesn't sound familiar. Used to have it in the BMW cradle but replaced that with the Garmin cradle (in the original place in the dash) in order to be able to hard wire it to the Autocom.
      Does the message appear on the bike or on the nav?
      Frank (NLD),             BMW K1600 GT Red (2011); top case w/brakelight, comfort package, safety package, F2P, black Wunderlich bars, PDM60, Autocom SPA  |  Other bike: Moto Guzzi V7 850 California (1975)

      OfflineRTman10

      • Hero Member
      • *****
      • Posts: 935
      • Country: england
      • GTL Exclusive (Exchanged for R1200RT LE)
        Re: GARMIN 660 COMPATABILITY PROBLEM
        « Reply #2 on: 2015-02-10 16:11:00 »
        Just comes up on the 660 screen when its put in the cradle. Then goes off and it works normally with prompts coming through the speakers. Not mine by the way.